Office 365

Minor incident Office 365
2023-01-25 08:11 BST · 1 day, 1 hour, 8 minutes

Updates

Resolved

Microsoft has resolved the problem.

January 26, 2023 · 09:19 BST
Issue

There appears to be problems with Office 365. These are confirmed as MICROSOFT issues and not internal.

You may experience trouble with emails or with accessing anything that relies on Office 365 to login.

We will monitor and try to ensure as minimal impact as possible although we are very limited because the issue is external and out of our hands.

January 25, 2023 · 08:14 BST

← Back